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Database Tips (Exercise 1) 

Rules for a List 

• Keep all records together – no blank rows/columns in the data 

• Be consistent with the data fields 

• Each column heading must be named 

• Blank row between the title and the column heading 

Sort a Single Level 

1. Click in one cell of the column to sort 

2. On the Home tab, in the Editing group, click the Sort & Filter button. 

3. Select Sort A to Z or Sort Z to A button 

Sort the records of a list by the entries in two or more fields 

1. Select any cell in the list 

2. Home tab, Editing group, Sort & Filter, click Custom Sort 

3. Click the Sort By drop-down list, select the first sort field  

4. Click the Add Level button to sort another level  

5. Optionally, change the sort order for any sort field (Ascending or Descending). Click OK 

Filter a List 

1. Right-click in the cell you want to filter by 

2. Select Filter, Filter by Selected Cell’s Value 

Subtotals 

1. Sort the column to be grouped together  

2. Click Data tab, Outline group, Subtotal 

3. Set the At each change in box so it matches the column sorted 

4. Set the Add subtotal to: to a column that has numbers in it.  Click OK 

5. To look at the subtotals, click on the number 2 in the top left corner Outlining Toolbar 

Remove Subtotals 

1. Click on the Data tab, in the Outline group, select Subtotal  

2. Click on Remove All button 

Add Select Visible Cells to the Quick Access Toolbar 

1. At the far right of the Quick Access Toolbar, click 
Customize Quick Access Toolbar  

2. Select More Commands, Select All Commands 

3. Scroll down and click on Select Visible Cells. Click the Add button.  
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Use Select Visible Cells Feature 

1. Highlight all cells that you want to copy (some cells may be hidden and you do not 
want to copy those cells), Click Select Visible Cells from the Quick Access Toolbar.  

2. Right-click the selected area, Copy 

3. Move to the cell you would like to paste the cells, right-click and select Paste 

Working with the Table Feature 

Create a Table with the Default Table Style 

1. Place the cursor in the data you want to convert to a table 

2. Select Insert, Tables, Table 

3. If using header columns, check the box for “My table has headers”. Click OK

 

Activate the Total Row in a table 

1. Place the cursor within your table 

2. On the Design Tab, in the Table Style Options group, select Total Row 

3. The sum total will appear in the last column by default, but you can click in any cell in the total 
row, and choose a function from the drop-down list in the cell. If the last column contains 
text, the function for the total field will be a Count of the number of records. 

Remove the table feature from the data 

1. Remove the Filter (if one is set) 
Data, Sort & Filter, Clear 

2. Turn off the Total Row (if checked) 
Design, Table Style Options, uncheck the Total Row 

3. Clear the Table Style 
Design, Table Styles, click the More button, Clear  

4. Select Design, Tools, Convert to Range. Click Yes to convert the table to a normal range 
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Insert and Delete Table Rows and Columns 

Inserting rows or columns in a table will only add within the table. The easiest way to insert is to click 
the column to the right of your data or the row below the data and start typing. If you have data to 
the right of, or below the table, that data is not affected.  

 

To insert within the table: 

1. Place your cursor in your data range. 

2. Right click in a cell of the row or column where you want to insert. 

3. Select Insert  

a. Table Columns to the Left 

 or  

b. Table Rows Above 

Tip: If the table includes a total row, you can insert a new row at the bottom but above the total row 
by selecting the bottom-right table cell and pressing Tab. 

 

PivotTables 

Creating a PivotTable 

A PivotTable must include the following: 
 (Row(s) Source, Column Source and a Data Source)  

The insert tab allows you to easily insert a PivotTable.  When PivotTables are 
inserted, the right pane of your spreadsheet will be the Drop Zone.  The Drop 
Zone allows you to easily drop fields in the columns, rows and value fields.  

How to Create a PivotTable 

1. Place your cursor in your data range. 

2. On the Insert tab, Tables group, select PivotTable. Click OK. 

3. In the PivotTable Field list pane, drag and drop the fields you want in 
your pivot table to the appropriate drop zone or check the box and Excel 
will select where to place the PivotTable Fields. 

Sort and Filter a PivotTable 

1. Click on a Row or Column Label filter drop-down arrow. 

2. Choose your sort options or check the boxes for the data you want to filter. 

Set Number Formats in a Pivot Table 

1. Right-click in a cell containing a number, select Number Format 

2. Select the number format to set. 
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PivotTable Slicers 
The Slicers feature enables you to slice data and include only 
the elements you want in PivotTables & PivotCharts.  It 
allows you to add and remove elements from the table 
display so that you can compare and evaluate data from 
different perspectives. Also use Slicers with multiple 
PivotTables & PivotCharts to showcase your data consistently in a variety of scenarios.  

Insert a Slicer 

1. Click in the PivotTable Field List pane, select an item. 

2. Select Insert, Filter, Slicer. 

3. In the Insert Slicers dialog box, select an item and click OK.  

4. In the Slicer that appears, click each item to observe the change in the corresponding item. 

5. To select multiple items, hold Ctrl while selecting each additional item. 

Create a PivotChart  

1. Place your cursor in your PivotTable. 

2. On the PivotTable Tools Analyze tab, Tools 
group, select PivotChart. 

3. Choose a Chart layout. 

Format a PivotChart 

1. Click in your PivotChart. 

2. A PivotChart Tools Ribbon will display additional 
tabs. (Design, Format and Analyze tabs) 

Update a PivotTable or PivotChart Report 

1. Click in the original Database or list  

2. Make the necessary changes to the data 

3. Click on the PivotTable or PivotChart 

4. Click the Refresh button on the PivotTable Tools, Analyze tab, or right-click and select 
Refresh. 
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Naming Ranges (Exercise 2) 

Name a Range using the Name Box 

1. Select the range of cells  

2. Click in the Name box 

3. Type a name for the range and press Enter.  

Name a range using the adjacent label 

1. Select the range of cells along with the column headings and row headings for the range 

2. On the Formulas tab, in the Defined Names group, click Create From Selection 

3. Place a checkmark in Top Row and Left Column if the named range is for both columns and 
rows. Click OK. 

Change the Name or Range using the Menu 

1. On the Formulas tab, in the Defined Names group, click Name Manager  

2. Click on the range name, select Edit 

3. Type a new name for the range in the Name box, or change the cell reference in the Refers to 
box 

4. Click OK 

Bring separate items into a Single Column 

(Concatenate) 

1. Click in the cell to join the items 

2. Type = to create a formula 

3. Select the cell reference for first cell to join together.  

4. Type & between each cell reference 

5. Use “” to add words to the cells 

6. Example: =A1&””&B1 

Using the Flash Fill Feature 

This powerful new feature allows you to separate data similar to the Text to Columns feature but 
is easier to use.  

Flash Fill to Separate First and Last Name 

1. If you already have First and Last Name in a column, enter the first name in 
the column next to this column for the first person. 

2. Start typing the next first name for the second person. Flash Fill will show a 
list of suggested names.  

3. If it looks good, press Enter to accept the list or press ESC to remove the 
name. 

Tip – Instead of typing the second name, on the Data tab, in the Data Tools group, click Flash Fill. 
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The If Function 

Construct an IF Statement 

The IF function tests the results of an expression (logical test) and then performs one action of the 
expression is true, and another if it is false.  

 IF(logical_test, value_if_true, value_if_false) 

1. Select the cell to contain the IF function. 

2. Type =IF, then press ( 

3. Enter the logical test, then press , 

4. Enter the action to take if the condition is true, then , 

5. Enter the action to take if the condition is false. 

6. Press  ) to end the formula. 

7. Press Enter. 

SumIf Statement 

SUMIF –used to sum the values in a range that meet criteria that you specify.  
For example, sum if column D contains the word “life”, you would sum column B only for those cells 
that contain the word “life” 

Countif Statement 

Countif – counts the number of cells specified by a given set of conditions or criteria.  
For example =COUNTIFS($A$3:$S$27,"Life") will count how many times the word Life is listed in 
the cell range A3:S27.  

Combine the IF AND Statement 

IF AND – is used if you need two conditions to be met 
One common use for the AND function is to expand the usefulness of other functions that perform 
logical tests. For example, the IF function performs a logical test and then returns one value if the 
test evaluates to TRUE and another value if the test evaluates to FALSE. By using the AND function 
as the logical_test argument of the IF function, you can test many different conditions instead of 
just one. 
Example: =IF(OR(E8>=40,AND(B8>=11,C8>=11,D8>=11)),100,"") 
In the above example AND is used to make sure that B8, C8, and D8 are all greater than 11. 

Combine the IF OR Statement 

IF OR – is used if you need either of two conditions to be met 
 
Example: =IF(OR(E8>=40,AND(B8>=11,C8>=11,D8>=11)),100,"") 
In the above example, OR is used to add the number 100 to cell F8 if E8 is greater than or equal to 
40, or if B8, C8, and D8 are all greater than 11. 
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Lookup Basics & Reference Functions 

VLOOKUP  

There are two types of lookup functions.  The setup of the table, and the direction of the lookup 
determine which lookup function is appropriate. VLOOKUP- searches vertically through the first 
column of the lookup table.  HLOOKUP- searches horizontally through the first row of a lookup 
table. 

=vlookup(lookup value, table array, column index number,[range lookup]) 

1. Select cell to contain the lookup value.  Type =vlookup( 

2. Enter value or cell reference containing the value to look up, then press , 

3. Select or enter the range of cells containing the table and press F4 (the table becomes an 
Absolute reference), then press , 

4. Enter the column number from which to pull the answer 

5. Type , False for an exact match or leave blank for a close match 

6. Press ) to complete the formula 

7. Press Enter 

Match Function 

Match returns the relative position of an item in an array that matches a specified value in a 
specified order. 
Using the Match function with a vlookup eliminates the need to count columns. 
 
In the example below, vlookup will look for the ninth column, which is the Annual Cost of Tickets.  
Replace the Column Number in the vlookup function with the Match function.  The match function 
will look to “match” the Annual Cost of Tickets reference in cell D29 from the column headings in 

A1:J1. This is the column that will be used in the vlookup example. 
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Data Validation (Exercise 3) 

Data Validation 

Excel provides a data management feature called data validation that enables the user to create 
rules for the type of data that will be accepted in a data field.  Input and error messages can be 
defined to provide meaningful information to the user. 
1. Select the range of cells for which to define the validation rules 

2. On the Data tab, in the Data Tools group, click the Data Validation drop down list and choose 
Data Validation 

3. Click one of the three tabs and change the necessary settings. 
Settings- Specify the type of data the cell will accept. 
Input Message- Specify a message to appear when the cell is selected. 
Error Alert- Specify a message that appears if invalid data is entered. 

Use a Different Worksheet w/Valid Data 

If you are referencing a cell in another worksheet, make sure you create a named range for the data.   

Create Named Range 

1. Create a named range by selecting the cells to be used in your valid data list.  

2. Click in the name box in the formula bar, name that range, and then press Enter.  Pressing 
Enter saves the Named Range.  

Note: Don't include spaces in name. (i.e. GradeComments.) 

Create Data Validation Settings  

On the sheet you want to use the valid data, select all the cells you want to apply this list to, or 
select the column selector to select the entire column.  
1. Click on Data tab, Data Tools group, select Data Validation. From the Allow drop down, select 

List. 

2. In the source field, type =NamedRange.   
(i.e. =GradeComments) 

 


